​ ​

Форум клана ЧПУшников

Информация о пользователе

Привет, Гость! Войдите или зарегистрируйтесь.



Ось X съезжает в право

Сообщений 1 страница 15 из 15

1

Построил станок. Добился плавного перемещения осией Y и X, но с момента запуска появилась появилась проблема. Ось Х сьезжает в право после каждого прохода на 0.5 миллиметра примерно.
Менял местами драйвера, менял на плате мач 3 с лпт разьемы для подключения оси х. Переставлял на Б с переименовыванием пинов. Заземлил станок и шпиндель. Проблема сохранилась.
Удалось решить проблему включением оси Б в подчинение Х но теперь координаты начали сползать по Y
Нмогу понять в чем проблема. Глучная плата, ЛПТ кабель или может что то не выставил в настройках.
Поставил параметры степ и дир в мотор анд тюнс  25 и 5 ставил разные. Ничего не менялось.
Может у меня глючный мач?  винда семерка чистая. Ничего кроме мача на на ней нет. Версия мача R3.041

0

2

Наверное проблема в механике,непонятно какой станок ,как сделан,какие настройки,но если двигатель соединён с винтом через муфту,то проверьте её фиксацию,да и собственно фиксацию всех элементов

0

3

mfamilie написал(а):

Наверное проблема в механике,непонятно какой станок ,как сделан,какие настройки,но если двигатель соединён с винтом через муфту,то проверьте её фиксацию,да и собственно фиксацию всех элементов

Проблема не в механике.
Скидывал ремни ставил метки и запуска простую УП колесо с 5ю отверстиями.
При повторном запуске УП Rewnd смещение на одинаковую длинну. Ничего не могу сделать. Бился неделю толку нет.
Драйвера ST4045A1 шаговики nema23
Плата такая
Смещение шагов по X и Y примерно одинаковое

0

4

https://i.imgur.com/ZRdEZiZm.jpg
Плата такая

0

5

Пожалуйста подскажите кто сталкивался. Пробовал кучу разных mach3 везде глюк одинаковый.
У меня PCI-E LPT контроллер. Может дело в нем?

0

6

Почему бы вам не попробовать, подключить драйвера по У параллельно?

0

7

Dark Knight написал(а):

Почему бы вам не попробовать, подключить драйвера по У параллельно?

На остальных осях тоже уходит
Везде одинаково и системно. Галки step low и Dir ставил без результатно
Прблема либо в плате ибо в по либо в pci e карточке LPT

0

8

как будто лишний аг при смене направления, но никак не лечится.
Заземление есть.

0

9

Max2199 написал(а):

как будто лишний аг при смене направления, но никак не лечится.
Заземление есть.

Может медленные оптопары, вот и не успевает, либо контакт хреновый

0

10

Max2199
А почему Вы так уверены что проблема не в механике?Вы бы всё-таки показали как у Вас механика сделана,а то из описания ничего не понять.В вашей плате мозгов никаких нет,просто стоят оптопары и всё,чтобы она так влияла-это нонсенс.И что в мотор тюнинге всё меняли и это не сказалось никак на работе?,так не бывает.

0

11

Max2199 написал(а):

Заземление есть.

Системник заземлен?
Кабель LPT имеет экран?

0

12

Всем привет. Чтобы не создавать новую тему, напишу здесь. Проблема аналогичная, но...
Станку пять лет, работает раз в месяц, плюс-минус. Все было здорово, однако в последнее время идет явное накопление ошибки по оси у.
Чем дольше работает, тем больше ошибка - до 10 мм доходила. По остальным осям все здорово, проблем нет.
В какую сторону рыть: механника или програмная ошибка?
Подскажите, кто может...
Станок ручной сборки (помогли люди добрые), не фирма. Все время работал без нареканий.
А тут при вырезании букв "никто не забыт" в дереве толщиной 20 мм за семь проходов, с глубиной 3 мм за каждый, с каждого прохода ошибку по У накапливает до 3 мм.
Раньше такой беды не было от слова совсем. И по 5 мм за проход снимал...

Или, может, уже обсуждалась проблема, ткните носом, где почитать...

Отредактировано Olsa (28-07-2021 17:08:37)

0

13

Olsa написал(а):

Всем привет. Чтобы не создавать новую тему, напишу здесь. Проблема аналогичная, но...
Станку пять лет, работает раз в месяц, плюс-минус. Все было здорово, однако в последнее время идет явное накопление ошибки по оси у.
Чем дольше работает, тем больше ошибка - до 10 мм доходила. По остальным осям все здорово, проблем нет.
В какую сторону рыть: механника или програмная ошибка?
Подскажите, кто может...
Станок ручной сборки (помогли люди добрые), не фирма. Все время работал без нареканий.
А тут при вырезании букв "никто не забыт" в дереве толщиной 20 мм за семь проходов, с глубиной 3 мм за каждый, с каждого прохода ошибку по У накапливает до 3 мм.
Раньше такой беды не было от слова совсем. И по 5 мм за проход снимал...

Или, может, уже обсуждалась проблема, ткните носом, где почитать...

В первую очередь проверьте механику, ну и фото пациента в студию

0

14

Olsa написал(а):

Станку пять лет, работает раз в месяц, плюс-минус. Все было здорово, однако в последнее время идет явное накопление ошибки по оси у.
Чем дольше работает, тем больше ошибка - до 10 мм доходила. По остальным осям все здорово, проблем нет.
В какую сторону рыть: механника или програмная ошибка?
Подскажите, кто может...
Отредактировано Olsa (Вчера 17:08:37)

Проверьте механику в первую очередь. Гайки ШВП, подшипники винтов и подожмите муфты. Во вторую очередь - проверьте блок питания и драйвер Y на предмет вздутых/потекших электролитов по питанию. Ну и все клеммы по оси Y подожмите.

0

15

blex написал(а):

Проверьте механику в первую очередь. Гайки ШВП, подшипники винтов и подожмите муфты. Во вторую очередь - проверьте блок питания и драйвер Y на предмет вздутых/потекших электролитов по питанию. Ну и все клеммы по оси Y подожмите.

Спасибо, попробую!!!
По поводу фото, пока не могу выложить, но если совет blex'а не поможет, выложу фото (станок в гараже, как пойду чинить, так и сфотографирую)!
Очень надеюсь, что поможет!!!

0

Быстрый ответ

Напишите ваше сообщение и нажмите «Отправить»